I have just came across another wallet version

I have just came across another wallet version

 

169900 is a version that implements a certain feature required for upgrading older wallets to support split HD chains (introduced in version 139900). It exists because the upgrade mechanism required a new version for this necessary feature to be implemented.

The feature added is a pre-HD split keypool. This allows users who upgrade from prior to HD chain split to still use their pre-split keypool. The version number had to be incremented in order to allow the upgrade to work – it is not possible to upgrade a pre-HD split wallet to 139900, the upgrade must be to 169900.

New wallets use 169900 as their version number because it happens to be highest version number.



Source link

Leave a Comment

Your email address will not be published. Required fields are marked *